Probleme mit Teamviewer nach Update

Bei einem Kunden hatte ich nach der Aktualisierung von 12.04 auf 14.04 das Problem, dass Teamviewer nicht mehr funktioniert.

Auch nicht nach Deinstallation der „alten“ Version und Installation der neuen Version.

Die Fehlermeldung war

Der Teamviewerdaemon läuft nicht

Ich habe mehrere Dinge probiert, aber folgendes führte zum Erfolg: Ich habe ein Script namens /etc/init.d/teamviewer angelegt mit folgendem Inhalt:

#!/bin/sh
#
# /etc/init.d/teamviewer
#
### BEGIN INIT INFO
# Provides: teamviewer
# Required-Start:
# Required-Stop:
# Default-Start: 2
# Default-Stop: 5
# Short-Description: teamviewer daemon initialization
### END INIT INFO


usage() {
    echo "Usage: $0 
{start|stop|restart|reload|force-reload|status|recache}"
}


case "$1" in
        start)
                teamviewer --daemon start
                ;;
        stop)
                teamviewer --daemon stop
                ;;

        restart|reload|force-reload)
                teamviewer --daemon stop
                teamviewer --daemon start
                ;;
        esac
exit $rc

Danach habe ich mit dem bootupmanager (bum) das Script in Runlevel 2 an Position 80 starten lassen. Danach funktionierte alles wie gewünscht!

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s